# Help me please , I have failed to start HAproxy

**URL:** https://discourse.haproxy.org/t/help-me-please-i-have-failed-to-start-haproxy/4018
**Category:** Help!
**Created:** [July 5, 2019, 5:08am UTC](https://discourse.haproxy.org/t/help-me-please-i-have-failed-to-start-haproxy/4018 "2019-07-05T05:08:39Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![PEACE](https://avatars.discourse-cdn.com/v4/letter/p/c68b51/32.png) [@PEACE](https://discourse.haproxy.org/u/PEACE)
#### Post date: [July 5, 2019, 5:08am UTC](https://discourse.haproxy.org/t/help-me-please-i-have-failed-to-start-haproxy/4018/1 "2019-07-05T05:08:39Z")

</div>

i just newbie, i want to build HAproxy with my computer, with localhost using VMware. i have 3 servers, and i done with my configuration. but something happen when i want to start my HAproxy configuration. the configuration FAILED, can u please tell me where is the error with my configuration?  
here is my configuration :

global  
log /dev/log local0  
log 127.0.0.1 local1 notice  
maxconn 4096  
chroot /var/lib/haproxy  
stats socket /run/haproxy/admin.sock mode 660 level admin  
stats timeout 30s  
user haproxy  
group haproxy  
daemon

```
# Default SSL material locations
ca-base /etc/ssl/certs
crt-base /etc/ssl/private

# Default ciphers to use on SSL-enabled listening sockets.
# For more information, see ciphers(1SSL). This list is from:
# https://hynek.me/articles/hardening-your-web-servers-ssl-ciphers/
# An alternative list with additional directives can be obtained from
# https://mozilla.github.io/server-side-tls/ssl-config-generator/?server=haproxy
ssl-default-bind-ciphers ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:RSA+AESGCM:RSA+AES:!aNULL:!MD5:!DSS
ssl-default-bind-options no-sslv3

```

defaults  
log global  
mode http  
option httplog  
option dontlognull  
retries 3  
option redispatch  
maxconn 2000  
conntimeout 5000  
clitimeout 50000  
srvtimeout 50000

listen loadbalance 0.0.0.0:1936  
mode http  
stats enable  
stats uri /haproxy?stats  
option httpclose  
option forwardfor  
balance roundrobin  
server webserver1 10.20.20.10:80 check  
server webserver2 10.20.20.20:80 check

and the error said :

 ![image](https://us1.discourse-cdn.com/flex016/uploads/haproxy/original/1X/4ed3490e2e7616f4e3758b9770dc9180c55436f4.png) ![image|690x352]

i will be appreciate and will get much knowledge from u master, thanks for your attention and your time 😊

---

<div class="post-metadata">

### Author: ![ciprian.craciun](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.haproxy.org/ciprian.craciun/32/722_2.png) [@ciprian.craciun](https://discourse.haproxy.org/u/ciprian.craciun)
#### Post date: [July 5, 2019, 5:28am UTC](https://discourse.haproxy.org/t/help-me-please-i-have-failed-to-start-haproxy/4018/2 "2019-07-05T05:28:11Z")

</div>

Could you perhaps run `haproxy -c -f /etc/haproxy/haproxy.cfg` (adapt if necessary), which checks and reports if there is something wrong with the configuration file.

Perhaps also try to run it in the foreground as `haproxy -d -f /etc/haproxy/haproxy.cfg`

---

<div class="post-metadata">

### Author: ![PEACE](https://avatars.discourse-cdn.com/v4/letter/p/c68b51/32.png) [@PEACE](https://discourse.haproxy.org/u/PEACE)
#### Post date: [July 5, 2019, 6:03am UTC](https://discourse.haproxy.org/t/help-me-please-i-have-failed-to-start-haproxy/4018/3 "2019-07-05T06:03:38Z")

</div>

done . i change my haproxy.cfg , like this :  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/haproxy/original/1X/5b469ae616e8868f55f6bf14f391615959e699c4.png)

and its works :

 ![image](https://us1.discourse-cdn.com/flex016/uploads/haproxy/original/1X/04adc735417b351e967d26125857088b8248aef9.png)

Thank you for responding  
😊
