# Help me please, i try HAproxy on my computer with VMware

**URL:** https://discourse.haproxy.org/t/help-me-please-i-try-haproxy-on-my-computer-with-vmware/3002
**Category:** Help!
**Created:** [September 15, 2018, 2:48pm UTC](https://discourse.haproxy.org/t/help-me-please-i-try-haproxy-on-my-computer-with-vmware/3002 "2018-09-15T14:48:38Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Grooth](https://avatars.discourse-cdn.com/v4/letter/g/ea5d25/32.png) [@Grooth](https://discourse.haproxy.org/u/Grooth)
#### Post date: [September 15, 2018, 2:48pm UTC](https://discourse.haproxy.org/t/help-me-please-i-try-haproxy-on-my-computer-with-vmware/3002/1 "2018-09-15T14:48:38Z")

</div>

i still try common HAproxy configuration on my computer, after i have stupid problem because my fault before now i have another problem. and here is my servers configuration. this is OFFLINE and using LOCALHOST.

server1 using IP: 10.10.10.2/29  
server2 using IP: 10.10.10.3/29  
server3 using IP: 10.10.10.4/29  
all server using host name: jarkom

my load balancing using IP: 172.23.23.5/29

my firewall and connection i think on good condition because all of them can pinging each other.

and here my HAproxy script:

root@ubuntu:/home/jarkom# cat /etc/haproxy/haproxy.cfg  
global  
log 127.0.0.1 local0 notice  
maxconn 2000  
user jarkom  
group jarkom  
daemon

defaults  
mode http

frontend http-in  
bind 172.23.23.5:80  
default\_backend webservers  
timeout connect 100  
timeout client 100  
timeout server 100

backend webservers  
server web01 10.10.10.2:80  
server web02 10.10.10.3:80  
server web03 10.10.10.4:80  
balance roundrobin  
timeout connect 100  
timeout client 100  
timeout server 100

and then when this error show to me…

● haproxy.service - HAProxy Load Balancer  
Loaded: loaded (/lib/systemd/system/haproxy.service; enabled; vendor preset: enabled)  
Active: active (running) since Sat 2018-09-15 21:39:07 WIB; 2min 51s ago  
Docs: man:haproxy(1)  
file:/usr/share/doc/haproxy/configuration.txt.gz  
Process: 3928 ExecStartPre=/usr/sbin/haproxy -f $CONFIG -c -q $EXTRAOPTS (code=exited, status=0/SUCCESS)  
Main PID: 3929 (haproxy)  
Tasks: 2 (limit: 2307)  
CGroup: /system.slice/haproxy.service  
├─3929 /usr/sbin/haproxy -Ws -f /etc/haproxy/haproxy.cfg -p /run/haproxy.pid  
└─3930 /usr/sbin/haproxy -Ws -f /etc/haproxy/haproxy.cfg -p /run/haproxy.pid

Sep 15 21:39:07 ubuntu systemd[1]: Starting HAProxy Load Balancer…

> **Sep 15 21:39:07 ubuntu haproxy[3929]: [WARNING] 257/213907 (3929) : parsing [/etc/haproxy/haproxy.cfg:14] : ‘timeout connect’ will be ignored because frontend ‘http-in’**  
> **Sep 15 21:39:07 ubuntu haproxy[3929]: [WARNING] 257/213907 (3929) : parsing [/etc/haproxy/haproxy.cfg:16] : ‘timeout server’ will be ignored because frontend ‘http-in’**  
> **Sep 15 21:39:07 ubuntu haproxy[3929]: [WARNING] 257/213907 (3929) : parsing [/etc/haproxy/haproxy.cfg:24] : ‘timeout client’ will be ignored because backend 'webservers**  
> Sep 15 21:39:07 ubuntu systemd[1]: Started HAProxy Load Balancer.

when i try on browser, i check with load balancing IP but that is error “503” thats said cant reach server.

can someone explain me what wrong with my work?.. i will be appreciate if u tell me where is the wrong… thanks a lot for your attention and i hope god will be with u forever… 😇

---

<div class="post-metadata">

### Author: ![AaronWest](https://sea2.discourse-cdn.com/flex016/user_avatar/discourse.haproxy.org/aaronwest/32/164_2.png) [@AaronWest](https://discourse.haproxy.org/u/AaronWest)
#### Post date: [September 16, 2018, 11:42am UTC](https://discourse.haproxy.org/t/help-me-please-i-try-haproxy-on-my-computer-with-vmware/3002/2 "2018-09-16T11:42:41Z")

</div>

Hi Grooth,

Firstly, the errors you see about timeout’s is because they are declared in the frontend too, nothing to worry about though as these are just warnings.

The bigger issue for me would be proving the availability of the real servers, can you connect to

```auto
server web01 10.10.10.2:80
server web02 10.10.10.3:80
server web03 10.10.10.4:80

```

Using curl/wget from the box running HAProxy…? Because you have no health check defined it’s hard to know if it’s even really accessible.

---

<div class="post-metadata">

### Author: ![Grooth](https://avatars.discourse-cdn.com/v4/letter/g/ea5d25/32.png) [@Grooth](https://discourse.haproxy.org/u/Grooth)
#### Post date: [September 23, 2018, 7:10pm UTC](https://discourse.haproxy.org/t/help-me-please-i-try-haproxy-on-my-computer-with-vmware/3002/3 "2018-09-23T19:10:15Z")

</div>

i think, i have problem with my connection configuration or on my xampp configuration because when i do health check this is happen:

jarkom@ubuntu:~$ curl 10.10.10.2  
curl: (7) Failed to connect to 10.10.10.2 port 80: No route to host

jarkom@ubuntu:~$ wget 10.10.10.2  
–2018-09-24 02:03:06-- [http://10.10.10.2/](http://10.10.10.2/)  
Connecting to 10.10.10.2:80… failed: No route to host.

jarkom@ubuntu:~$ wget 172.23.23.5  
–2018-09-24 02:05:33-- [http://172.23.23.5/](http://172.23.23.5/)  
Connecting to 172.23.23.5:80… connected.  
HTTP request sent, awaiting response… 503 Service Unavailable  
2018-09-24 02:05:33 ERROR 503: Service Unavailable.

thanks for reply my question your respond very helpful.  
so if u see that health check, what is wrong?.. my server or my connection? thanks before.
