# Unable to load private key

**URL:** <https://discourse.haproxy.org/t/unable-to-load-private-key/3613>\
**Category:** Help!\
**Created:** [March 13, 2019, 6:50am UTC](https://discourse.haproxy.org/t/unable-to-load-private-key/3613 "2019-03-13T06:50:47Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gayathri](https://avatars.discourse-cdn.com/v4/letter/g/838e76/32.png) [@Gayathri](https://discourse.haproxy.org/u/Gayathri)\
**Post date:** [March 13, 2019, 6:50am UTC](https://discourse.haproxy.org/t/unable-to-load-private-key/3613/1 "2019-03-13T06:50:48Z")

</div>

Hi All,

I am getting the below error while starting HAProxy service.

root@ABC keys]# /usr/local/cm/bin/haproxy -D -f /usr/local/cm/conf/haproxy.conf

[ALERT] 026/113546 (22869) : parsing [/usr/local/cm/conf/haproxy.conf:28] : ‘bind :::6971’ : unable to load SSL private key into SSL Context ‘/usr/local/cm/.security/CallManager/keys/HAProxy.pem.rsa’.

I have compared my cert and key corresponding to the HAProxy.pem.rsa and its matching. Could you please help me to solve this issue.

Thanks,  
Gayathri
