HAProxy community

Backend stuck in MAINT resolution

I was testing a bit with scaling a backend, increasing instances and deleting them and now I am stuck in MAINT resolution for 20 minutes.

I am getting this in the logs

haproxy[2374513]: radosgw/radosgw21 changed its FQDN from (null) to rgw2.prod-meeoa-s3.marathon.mesos by 'SRV record'
haproxy[2374513]: radosgw/radosgw21 changed its FQDN from (null) to rgw2.prod-azzdy-s0.marathon.mesos by 'SRV record'

This is what I have in the config

server-template radosgw1 1  _https._rgw1.prod._tcp.marathon.mesos ssl weight 100 resolve-opts
server-template radosgw2 1  _https._rgw2.prod._tcp.marathon.mesos ssl weight 100 resolve-opts

It looks like it does not want to get the new ip. Because the srv fqdn has changed?
Should I add options to the server-template backend? Eg. to allow this fqdn to change in srv? Or is there different srv lookup I should use?

Both backends I can access with lynx.

When I do a reload of haproxy, the radosgw2 is detected L7OK200

I’m assuming this is the following bug, which affects 2.2.2:

It’s already fixed in the source tree, so 2.2.3 will work.

Ok nice