Error in HA-PROXY ACL after Upgrade

I had pfSense 2.6.0 with HAProxy package 0.61_11. I performed an upgrade to version 2.7.0 and HAProxy 0.63_1. After the upgrade, I encountered an error with a custom ACL: var(req.working_day) eq 1 || 2 || 3 || 4 || 5. I have properly defined the variable with the following http-request statement: http-request set-var(req.working_day) date,ltime(%u), and it was working fine. However, I am now getting the following error message: “Matching method must be specified first (using ‘-m’) when using a sample fetch of this type (‘var’).”

Any assistance or guidance regarding this issue would be highly appreciated. Thank you in advance!

Please provide the full configuration.

It is impossible to understand the context without it and considering that the error message specifically criticises the sequence, the full configuration is absolutely necessary.

The ACL statement seems completely wrong to me and I doubt it ever worked as expected, even in old releases.

2.7.0 is a short term support release and will be EOL in a few months. It’s a .0 version and over 400 bugs have been solved since it’s release. It’s about the worst version you could possibly use in production. Use 2.7.10 if you must use 2.7. Otherwise please use LTS release branches and try to avoid .0 version generally.

To be clear: I think it’s very unlikely that this is a config parser bug though. The configuration was probably wrong all along, only now there is a warning.

in the acl, just replace eq with -m int eq