HAproxy SSL-termination mode in http/2 doesn't support push stream

Hi! When I tried to use HAproxy as a reverse proxy of my http/2 origin with server push, I got an error as follow:
Error [ERR_HTTP2_PUSH_DISABLED]: HTTP/2 client has disabled push streams
at ServerHttp2Stream.pushStream (internal/http2/core.js:2375:13)
It seems that the SSL-termination mode doesn’t support nodejs’s push stream. But I also have a try on SSL-pass through mode and it worked. So, I wonder the support of HAproxy in push stream, especially in SSL-termination mode. Why does HAproxy disable push streams in SSL-termination mode? What can I do to enable server push stream in SSL-termination mode? I know that Link header can do that, but I don’t want to use link header for some reasons. I need some helps. Here is my configuration sample of SSL-termination mode:

frontend front
bind *:443 ssl crt /home/cpj/http2server/servername.pem alpn h2,http/1.1
mode http
default_backend nodejs

backend nodejs
mode http
server chenpinji ssl alpn h2,http/1.1 verify none

Thank you!