[Solved] HAProxy start adding to queue even if maxconn is not reached


#1

Hi All.

For some time, I’m trying to figure out why Haproxy begins to queue even if the number of maxconn hasn’t been reached. I think I’ve tried all the possibilities to configure and reconfigure it and still haven’t got an result.

The implementation is like this: web server <> HAProxy <> database server .

Everything seems to work just fine, the haproxy works properly until it reach a point when starts to queue, even if the database server supports more than 200 concurrent queries. For test purposes, I’ve made 40 concurrent queries to that server, but at some point the haproxy queue begin to increase. Here is the log of that test http://pastebin.centos.org/39671/55266771/raw/ and as you can see, after the 20th query begins to queue.
The configuration is this http://pastebin.centos.org/39676/67677145/raw/ .

Most likely there is something that I miss but cannot figure out what.

Thank you for your time.


#2

Please remove the minconn parameters and refer to the documentation of the parameters below:

http://cbonte.github.io/haproxy-dconv/snapshot/configuration-1.6.html#minconn
http://cbonte.github.io/haproxy-dconv/snapshot/configuration-1.6.html#fullconn


#3

@Baptiste - Thank you so much for this information. You’ve made me very happy.
Thank you again very much.