HAProxy community

Disable HTTP/2 in v2.0

Hi, We were using v1.6 for a long time, but we had to enable x-request-start headers, which was fully working in v1.9.

But Is there any way to disable Http/2 in the latest version? It breaks our headers (lowercase)

I tried no option http-use-htx but It doesn’t work as it should.

HTX breakes your headers, not http/2.

You disable HTX, as you correcty say, by using no option http-use-htx, however it needs to be in both in the front and the backend (or in a default section covering both).