HA 2.2 connection header disappeared

Hi,
I have the following test installation on HA-Proxy version 2.2.4-1ppa1~bionic 2020/10/02:
defaults
log global
mode http
option httplog
option dontlognull
timeout connect 5000
timeout client 50000
timeout server 50000
timeout http-keep-alive 2m

frontend test_tcp80
bind 10.220.44.3:80
option http-keep-alive
default_backend test_tcp80

backend test_tcp80
balance source
option prefer-last-server
option http-keep-alive
server iris 10.220.38.3:8001

I create http1.1 request. Request from client consists header ‘Connection: keep-alive’, but request from Haproxy to backend without this header.
Is this a bug or feature? It works as expected on 1.9. How can I solve this problem?
Thank you!

It’s not a problem. HTTP/1.1 implies Connection: keep-alive, it therefor doesn’t make sense to set this header in HTTP/1.1.