HAProxy community

HAProxy 1.9.4 http healthcheck for h2 backends


#1

All my backends support h2. http health check is failing as it is using h2 and marking the members down. If I remove the health check then everything works fine .

How do I force the health check to happen on http/1.1 instead of h2.

backend backend_java
balance leastconn
option http-use-htx
option httpchk GET /healthcheck HTTP/1.1

    server default_1_java 1.1.1.1:443 check ssl verify none alpn h2,http/1.1

    server default_2_java 2.2.2.2:443 check ssl verify none alpn h2,http/1.1

#2

I got this working after adding check-alpn http/1.1 in each server line.

backend backend_java
balance leastconn
option http-use-htx
option httpchk GET /healthcheck 

    server default_1_java 1.1.1.1:443 check check-alpn http/1.1 ssl verify none alpn h2,http/1.1

    server default_2_java 2.2.2.2:443 check check-alpn http/1.1 ssl verify none alpn h2,http/1.1```