HAProxy community

How to disable backend check?

Hi,

I have a haproxy (1.8.19) with a backend containing a single server node.

The server was not accessible for few minutes and haproxy considered this server as unavailable.

Feb 13 02:53:54 ip-172-31-42-147 haproxy[27944]: Server node1 is DOWN, reason: Layer4 timeout, check duration: 2002ms. 0 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
Feb 13 02:53:54 ip-172-31-42-147 haproxy[27944]: Servernode1 is DOWN, reason: Layer4 timeout, check duration: 2002ms. 0 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
Feb 13 02:53:54 ip-172-31-42-147 haproxy[27944]: backend backend has no server available!
*Feb 13 02:53:54 ip-172-31-42-147 haproxy[27944]: backend backend has no server available!

The server was unavailable at 02:53:54 and still at 09:32:00 until we’ve restarted haproxy.

Is there a way to disable http check or to set a periodic recheck of the server health?

Thanks.

Remove the check keyword to disable health checking. Configure health check intervals with inter.

1 Like

Thanks for your answer.

I’d though that the check was part of the “ssl no verify”

Seb.

It is not, no.