Metrics 0 value


#1

Alot of my vaules from the .sock file are of null “”. I’d also posted this on server fault before I found the community here:

That post is useful for seeing exactly the output I’m talking about. But there’s a bunch of details that don’t seem to be tracked by default. I was wondering can someone tell me why, and give advise on tracking these values?

{
    "slim": "",     // configured session limit
    "comp_byp": "", // bytes that bypassed the HTTP compressor
    "lastsess": "0",// seconds since last session assigned to server/backend
    "rate_lim": "", // configured limit on new sessions per second
    "req_rate": "", // HTTP requests per second over last elapsed second
    "comp_out": "", // HTTP response bytes emitted by the compressor
    "wredis": "0", // number of times a request was redispatched to another
    "dresp": "0", // responses denied because of security concerns.
    "ereq": "", // request errors. 
    "tracked": "", // id of proxy/server if tracking is enabled.
    "comp_in": "", // number of HTTP response bytes fed to the compressor
    "dreq": "", //  requests denied because of security concerns.
    "qlimit": "", // configured maxqueue for the server
    "hrsp_other": "0", // http responses with other codes (protocol error)
    "req_tot": "", //  total number of HTTP requests received
    "req_rate_max": "", //  max number of HTTP requests per second observed
    "hanafail": "0", failed health checks details
    "qcur": "0", // current queued requests
    "comp_rsp": "", // number of HTTP responses that were compressed
    "ctime": "0", // the average connect time in ms over the 1024 last requests
    "qtime": "0", // the average queue time in ms over the 1024 last requests
    "srv_abrt": "0", // umber of data transfers aborted by the server
    "throttle": "", // throttle percentage for the server, when slowstart
    "last_agt": "", / /last agent check contents or textual error
    "bck": "0", //  number of backup servers (backend)
    "qmax": "0",  // max value of qcur
}

Thanks