Move from 1.7 to 1.8


#1

Considering moving a keepalived HA setup to 1.8.4 from 1.7.9, and are wondering if 1.8 could peer stick-table w/1.7?

In this case we would attempt to fail-over service from active haproxy 1.7 to a 1.8 for a while and if successful later update passive 1.7 also to 1.8 and on error fail back to previous active 1.7 and revert 1.8 node.

Forget about it, just patch both nodes to 1.8.4 :slight_smile:


#2

For the record, not only does haproxy 1.7 and 1.8 use the same peer protocol (version 2.1), the peer protocol also interoperates between different releases.

This is not specifically documented, but we can see it from the commit message, like MEDIUM: peers: Fix a peer stick-tables synchronization issue.