HAProxy community

New To HAproxy Setting Up In a Test Lab

Hi,

I have a virtualbox lab with two servers with IIS installed and a test website i found called guitarbugs, which is internally accessible, and which is setup in IIS on both servers with working bindings for http.

As well as adding the site in DNS (on the DC), also with A records for both the servers which point to the guitarbugs site.

I can access the site fine on a windows 10 machine on the same LAN.

I have setup HAproxy for http for the time being to see how it works, but for some reason when i access the stats page i get no information on sessions when i access the page from the win 10 machine.

It’s almost as if it is not seeing the site.

If i turn off one of the servers the stats page registers that the server is down, but it is almost as if it doesn’t register actual sessions.

I’m not sure if there is some sort of special setup i have to do in IIS?. I just copied the sites folder to each server.

This is my config as well. I really do appreciate your help and assistance, as I’m stumped. Thanks again!

global
log /dev/log local0
log /dev/log local1 notice
chroot /var/lib/haproxy
stats socket /run/haproxy/admin.sock mode 660 level admin expose-fd listeners
stats timeout 30s
user haproxy
group haproxy
daemon

# Default SSL material locations
ca-base /etc/ssl/certs
crt-base /etc/ssl/private

# Default ciphers to use on SSL-enabled listening sockets.
# For more information, see ciphers(1SSL). This list is from:
#  https://hynek.me/articles/hardening-your-web-servers-ssl-ciphers/
# An alternative list with additional directives can be obtained from
#  https://mozilla.github.io/server-side-tls/ssl-config-generator/?server=haproxy
ssl-default-bind-ciphers ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:RSA+AESGCM:RSA+AES:!aNULL:!MD5:!DSS
ssl-default-bind-options no-sslv3

defaults
log global
mode http
option httplog
option dontlognull
timeout connect 5000
timeout client 50000
timeout server 50000
errorfile 400 /etc/haproxy/errors/400.http
errorfile 403 /etc/haproxy/errors/403.http
errorfile 408 /etc/haproxy/errors/408.http
errorfile 500 /etc/haproxy/errors/500.http
errorfile 502 /etc/haproxy/errors/502.http
errorfile 503 /etc/haproxy/errors/503.http
errorfile 504 /etc/haproxy/errors/504.http
frontend localnodes
bind *:80
mode tcp
default_backend web_servers

backend web_servers
mode tcp
balance roundrobin
server dc-1 192.168.100.2:80 check
server sql-1 192.168.100.3:80 check

listen stats
bind *:32700
stats enable
stats uri /
stats auth paul:123456
stats admin if TRUE