HAProxy community

Problem with reload haproxy

Hi, I’m having some issues with systemctl reload haproxy.
If i have haproxy running and i modify the backend file, when i do systemctl reload haproxy, the service won’t start it.
It seems that it won’t shut down correctly, i’ll leave here the systemctl status haproxy output after the reload:

[root@clhaproxy1 ~]# systemctl status haproxy -l
● haproxy.service - SYSV: HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high availability environments.
Loaded: loaded (/etc/rc.d/init.d/haproxy; bad; vendor preset: disabled)
Active: failed (Result: signal) since gio 2020-05-28 14:31:32 CEST; 2h 58min ago
Docs: man:systemd-sysv-generator(8)
Process: 80993 ExecStop=/etc/rc.d/init.d/haproxy stop (code=exited, status=0/SUCCESS)
Process: 80981 ExecReload=/etc/rc.d/init.d/haproxy reload (code=exited, status=0/SUCCESS)
Process: 10948 ExecStart=/etc/rc.d/init.d/haproxy start (code=exited, status=0/SUCCESS)
Main PID: 80988 (code=killed, signal=KILL)
CGroup: /system.slice/haproxy.service

mag 27 15:18:01 clhaproxy1 systemd[1]: Started SYSV: HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high availability environments…
mag 28 14:31:32 clhaproxy1 systemd[1]: Reloading SYSV: HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high availability environments…
mag 28 14:31:32 clhaproxy1 haproxy[80981]: /etc/rc.d/init.d/haproxy: line 26: [: =: unary operator expected
mag 28 14:31:32 clhaproxy1 haproxy[80981]: [WARNING] 148/143132 (80987) : Setting tune.ssl.default-dh-param to 1024 by default, if your workload permits it you should set it to at least 2048. Please set a value >= 1024 to make this warning disappear.
mag 28 14:31:32 clhaproxy1 systemd[1]: Reloaded SYSV: HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high availability environments…
mag 28 14:31:32 clhaproxy1 systemd[1]: haproxy.service: main process exited, code=killed, status=9/KILL
mag 28 14:31:32 clhaproxy1 haproxy[80993]: /etc/rc.d/init.d/haproxy: line 26: [: =: unary operator expected
mag 28 14:31:32 clhaproxy1 haproxy[80993]: Shutting down haproxy: [FALLITO]
mag 28 14:31:32 clhaproxy1 systemd[1]: Unit haproxy.service entered failed state.
mag 28 14:31:32 clhaproxy1 systemd[1]: haproxy.service failed.

You have systemd but are using the old unit.d script.

Please remove the unit.d script completely (delete the file) and install the systemd unit file, as per: