Error while Installing Hapoxy 1.7 on Debian 8


#1

HI,

I do not manage to install Hapoxy 1.7 on Debian 8.

I followed the instructions give by https://haproxy.debian.net for the stable version

Here is the error message obtained on the last step :

# apt-get install haproxy -t jessie-backports
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
haproxy est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 80 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Paramétrage de haproxy (1.7.5-2~bpo8+1) ...
**insserv: Script firewall.save.1 is broken: missing end of LSB comment.**
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement du paquet haproxy (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 haproxy
E: Sub-process /usr/bin/dpkg returned an error code (1)

The file firewall.save.1 is empty. I tryed to put classical headers but the error is still present.

I do have a firewall file for Iptables : /etc/init.d/firewall already field.

Do you have some ideas to solve this issue ?

Many thanks

Matthieu


#2

I solved it by deleting the corresponding file in the folder /etc/init.d/, that should have been created while I was configuring Iptables…
Now Haproxy is installed, and let’s use it !!