Freeze sockets in 1.8.1 (no http/2)


#1

After ~1.5 weeks uptime healthchecks of local web-server start showing errors “Too many sockets on the process”

It turned out that haproxy process uses 20000+ more file descriptors that it usually needs (in compare to another similar servers with 1.7.9 and much longer uptime).

According to /proc/net/sockstat it holded 10000+ “inuse” UDP-sockets.
Outgoing UDP-connections is used in LUA, but very rare.

Http/2 is disabled, reloads are used very often

Haproxy restart solved the problem and looks like now amount of UDP-sockets is slowly growing again


#2

Can confirm the same behavior on our systems…


#3

Hi,

I confirm it too. It is related to logs when HAProxy is started in master/worker mode. A new socket is opened when HAProxy is reloaded but the previous one is never closed. I posted a patch on the mailing list: https://www.mail-archive.com/haproxy@formilux.org/msg28283.html.

Could you check if it fixes your bug please ?

Thanks


#4

FYI, a fix has been pushed in upstream and will be backported in 1.8 very soon.