HAProxy community

HAProxy 2.0 HTTP/2 iisn't working with some browsers

Hi,

i installed HAProxy 2.0 (i also tested it on 2.0.1) and i added text alpn h2,http/1.1 to SSL frontend.
But when i activate onfiguration with alpn, i can’t display websites (browser always waiting for web) in some browsers (i did test with Firefox and Chrome). In another browser is all working (IE and Edge).
I tried also clear config only with one frontend and backend, but with same result.
In log isn’t any record about access, when i use Firefox or Chrome.
When i use IE or Edge, i see all HTTP/2 requests.
I tried it on two sepparate servers with same result.

Do you know, what is bad, when it doesn’t work with clear config too?

Thanks

You are probably affected by one of the bugs in 2.0.0, most likely the cookie bug.

Please try release 2.0.1, which fixes a huge number of them, including the cookie bug.

edit: sorry I can see that you already tried 2.0.1.

Yes, i tried, now i have installed version 2.0.1 :-/

@romor, could you share a request with all these headers coming from Firefox and another one from IE ? Share your configuration if possible, it could help.

Then, you have no log when a request hangs. But does the server receive it or not ?

Hi,

strange. I tried now after 3 hours again alpn parameter and now it’s working :slight_smile:
Why?:smiley: Some cache in haproxy?? Because of i did test on more PC’s before…
I hope, that problem will not exists sometime :slight_smile:
It’s working on both servers, on all computers.

Sometimes we see old haproxy process (old release or old configurations) not closing, and because the linux kernel load balances between old and new, strange behaviors occur.

To be sure nothing is running in the background I often execute a sudo killall haproxy (but of course, don’t do this in production when you need graceful restarts).