HAProxy community

Haproxy Splitted config loading issue

Hi,
i’m using Haproxy 1.8 on Debian 9 and under /etc/haproxy/ i have splitted my config file into haproxy.cfg , haproxyListen.cfg , haproxyRule1.cfg and haproxyRule2.cfg , the first file contains sections Global and default , the second file contains stats web page , and the last files contain frontend and backend rules…
i’m trying to load the config using the command haproxy -f /etc/haproxy/ it works but generates many pids ( 2 usual pids and third one ) and it causes problem after cuz the third PID ruin the service and doesn’t go away, and when i tried with haproxy -c -f /etc/haproxy/ i got “configuration file is valid” but it doesn’t load the other files … tried also to chain all files with their path together in the same command using -f but did’nt work also … Help plz :confused:

Why are you not using a service manager like systemd? What is the goal here to start haproxy manually?

That’s not a problem per-se.

It does not go away when doing what? What are you doing, what are you expecting to happen and what actually happens?

if it generates more than the 2 default PIDs, then any modification in haproxy will be handled by the third pid … i don’t know how to explain it but haproxy doesn’t work properly if there is more than 2 Pids (thats what i figured out )

I need you to answer all the questions, not only a single one, otherwise it will be difficult for me to help you.