HAProxy community

Lastchk showing L6ok/1mns

Sir
i have configured Haproxy with ssl-passthrough on centos 7 server as frontend and the same OS has been used for backend also. Haproxy is running fine on backend test page i.e httpd(apache) but it is not running on my php application on backend. Haproxy status showing its Lastchk as L6ok/1mns …my haproxy config below …plz help…
Global
# to have these messages end up in /var/log/haproxy.log you will
# need to:
#
# 1) configure syslog to accept network log events. This is done
# by adding the ‘-r’ option to the SYSLOGD_OPTIONS in
# /etc/sysconfig/syslog
#
# 2) configure local2 events to go to the /var/log/haproxy.log
# file. A line like the following can be added to
# /etc/sysconfig/syslog
#
# local2.* /var/log/haproxy.log

################################################################################3

Global settings

#---------------------------------------------------------------------
global

log         127.0.0.1 local2

chroot      /var/lib/haproxy
pidfile     /var/run/haproxy.pid
maxconn     4000
user        haproxy
group       haproxy
daemon

# turn on stats unix socket
stats socket /var/lib/haproxy/stats

#---------------------------------------------------------------------

common defaults that all the ‘listen’ and ‘backend’ sections will

use if not designated in their block

#---------------------------------------------------------------------
defaults
mode tcp
log global
option tcplog
option dontlognull
option http-server-close
option redispatch
retries 3
timeout queue 1m
timeout connect 10s
timeout client 1m
timeout server 1m
timeout check 10s
maxconn 3000

#---------------------------------------------------------------------

main frontend which proxys to the backends

#---------------------------------------------------------------------
frontend https-in
bind *:80
bind *:443
mode tcp
default_backend app

frontend stats
bind *:80
mode http
stats enable
stats uri /stats
stats realm HAProxy\ Statistics
stats auth admin:admin
stats refresh 10s
stats admin if { src 127.0.0.1 }

#---------------------------------------------------------------------

round robin balancing between the various backends

#---------------------------------------------------------------------
backend app
mode tcp
option ssl-hello-chk
balance roundrobin
server name of backend host x.x.x.x:443 check

i am using mode tcp i.e Layer 4 but here is status report showing Layer 6
Server
Cur Max Limit Cur Max Limit Cur Max Limit Total LbTot Last In Out Req Resp Req Conn Resp Retr Redis Status LastChk Wght Act Bck Chk Dwn Dwntme Thrtle
server 0 0 - 0 4 0 3 - 18 18 1m34s 10784 194855 0 0 0 0 0 24m23s UP L6OK in 23ms 1 Y - 0 0 0s -
Backend 0 0 0 4 0 3 300 18 18 1m34s 10784 194855 0 0 0 0 0 0 24m23s UP

thanks in advance