HAProxy community

Weird Status code and Termination State in log file

Hi everybody

I see some weird line in the log file as below. According to the document tc is -1 indicates that the connection between HA and backend never established. However the termination state is ---- indicates there is no error ?

The status code is -1 and I wonder if that will be sent back to client? If so it is really weird.

This problem only happens for a very small number of request and both HA and backend servers not busy.

We only see this problem after upgrade from 1.8 to 1.9.2

I am really appreciated if someone can help me to clear this out? Is it a bug of HA or if not what happen with these requests (with status -1)

14.162.149.32:51304 [21/May/2019:17:29:11.483] sale_https~ xxx_sale/api6-8000 0/0/-1/-1/13 -1 439 - - ---- 1245/563/35/5/0 0/0 {sale.xxx.com|} “OPTIONS /api/addressBooks/sync/fetch?BranchId=44299&IncludeRemoved=true&ModifiedDate=%222019-04-18T10:50:12.4764397%2B07:00%22 HTTP/1.1”
171.232.103.112:55108 [21/May/2019:17:29:14.333] sale_https~ xxx_sale/api6 0/0/-1/-1/31 -1 439 - - ---- 1204/522/30/3/0 0/0 {sale.xxx.com|} “OPTIONS /api/addressBooks/sync/fetch?BranchId=37361&IncludeRemoved=true&ModifiedDate=%222019-04-18T12:20:16.6459621%2B07:00%22 HTTP/1.1”
1.55.42.40:8865 [21/May/2019:17:29:17.306] sale_https~ xxx_sale/api6 0/0/-1/-1/35 -1 439 - - ---- 1259/680/45/7/0 0/0 {sale.xxx.com|} “OPTIONS /api/printTemplates/type/3?BranchId=121034 HTTP/1.1”
14.248.85.235:61942 [21/May/2019:17:29:20.753] guarantee~ guarantee/svc4-8000 0/0/-1/-1/8 -1 221 - - ---- 352/13/0/0/0 0/0 “OPTIONS /api/warranty?BranchId=172800&IsSyncData=true&ModifiedDate=%222019-05-15T10:09:29.8300000%2B07:00%22 HTTP/1.1”

Please don’t use 1.9.2, is full of awful bugs. If you want to use 1.9, use the latest stable.

We are unable to support a release that has 240 known, fixed bugs.

thanks Lucas,

I will try the latest stable 1.9.8 and get back to you (However we tried 1.9.6 and the problems still there )

We would like to use 1.9 since we need h2 with continuation support for our clients with WindowsXP :frowning:

Hi @lukastribus,

We update to latest version 1.9.8 and still get the problem. I’m going back to 1.8.20 for now but it seems like a bug with 1.9.x. I am really want to move to 1.9.x since we need h2.

really appreciated if you can take a look into the problem

TC -1 means the client has aborted:

“Tc” is the total time in milliseconds spent waiting for the connection to
establish to the final server, including retries. It can be “-1” if the
request was aborted before a connection could be established. See section
8.4 “Timing Events” for more details.

The client has aborted before a connection to the backend server could be established. I don’t see anything wrong with that. Did you have an actual issues or are you just concerned with new errors from the logs in 1.9? It could also be that 1.8 does not log this specific case, therefor the issue is more with 1.8 logging than it is with 1.9 generally.

Hi @Tim,

A patch was pushed few days ago in upstream. I backported it to 1.9 this morning. See http://git.haproxy.org/?p=haproxy-1.9.git;a=commit;h=db61c404. It should fix your issue.

1 Like

Hi @lukastribus, I see no error report from our customer yet when we update to 1.9.x
However It looks like a problem for us since it happens at the time when there is just a few request hit our server.
HA and backend servers in the same LAN.

Hi @capflam, so is this a bug or just logging issue as Lucas mention? and will it be included in fureture release?

thank you in advance

It sounds like a real issue, not just logging.

The fix will be in the v1.9.9 release, in the meantime you can apply it manually, use the 1.9 git tree or pick up the snapshot 1.9 20190525 tomorrow morning.

thanks much @lukastribus , @capflam, you save my days

I am really appreciated your help. I will switch back to 1.8.20 and wait for 1.9.9

again thank you and have a good day