Haproxy roundrobin strange behaviour?


#1

Hey folks!
I’ve configured haproxy like following:

defaults
    log     global
    mode    http
    option  httplog
    option  dontlognull
    retries 3
    option redispatch

frontend myApp
    bind 0.0.0.0:80
    use_backend abc

backend abc
    timeout queue 5000000
    timeout server 5000000
    timeout connect 5000000
    #bind 0.0.0.0:80
    mode http
    stats enable
    stats uri /haproxy?stats
    stats realm Strictly\ Private
    stats auth*
    stats auth*
    balance roundrobin
    #option httpclose
    #option forwardfor
    #option http-keep-alive
    cookie JSESSIONID prefix nocache
    server **** maxconn 1024 cookie check
    server **** maxconn 1024 cookie check

but on stats page i see:

How to configure fair round robin?

Thanks!


#2

Maybe leastconn is what you are looking for?

http://cbonte.github.io/haproxy-dconv/1.7/configuration.html#4.2-balance