HAPROXY solution with same device


#1

dear all,
i am configuring haproxy and keeplived and mysql server on same physical machine. but my load balancing is not working. request getting on mysql 1 server only. i am using the keeplived ip for requesting.
image


#2

Can you show your haproxy configuration? That’ll make it easier to give specific help!


#3

25 add-apt-repository ppa:vbernat/haproxy-1.6
26 apt-get update
27 apt-get install haproxy -y
28 cp /etc/haproxy/haproxy.cfg /etc/haproxy/haproxy.cfg.original
30 /etc/init.d/haproxy start
31 vim /etc/default/haproxy
32 vim /etc/haproxy/haproxy.cfg
global
log /dev/log local0
log /dev/log local1 notice
chroot /var/lib/haproxy
stats socket /run/haproxy/admin.sock mode 660 level admin
stats timeout 30s
user haproxy
group haproxy
daemon

    # Default SSL material locations
    ca-base /etc/ssl/certs
    crt-base /etc/ssl/private

    # Default ciphers to use on SSL-enabled listening sockets.
    # For more information, see ciphers(1SSL). This list is from:
    #  https://hynek.me/articles/hardening-your-web-servers-ssl-ciphers/
    ssl-default-bind-ciphers ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS
    ssl-default-bind-options no-sslv3

defaults
log global
mode http
option httplog
option dontlognull
timeout connect 5000
timeout client 50000
timeout server 50000
errorfile 400 /etc/haproxy/errors/400.http
errorfile 403 /etc/haproxy/errors/403.http
errorfile 408 /etc/haproxy/errors/408.http
errorfile 500 /etc/haproxy/errors/500.http
errorfile 502 /etc/haproxy/errors/502.http
errorfile 503 /etc/haproxy/errors/503.http
errorfile 504 /etc/haproxy/errors/504.http

listen mysql-galera-cluster 0.0.0.0:3307
#balance roundrobin
balance leastconn
mode tcp
option tcpka
option tcplog
option mysql-check user haproxy
server mdb1.example.com 192.168.25.87:3306 check weight 1
server mdb2.example.com 192.168.25.88:3306 check weight 1


#4

On the client, are you connecting towards the default mysql port 3306 or the TCP port you configured the load-balancer on, which is 3307?