HAProxy community

Help me please , I have failed to start HAproxy

i just newbie, i want to build HAproxy with my computer, with localhost using VMware. i have 3 servers, and i done with my configuration. but something happen when i want to start my HAproxy configuration. the configuration FAILED, can u please tell me where is the error with my configuration?
here is my configuration :

global
log /dev/log local0
log 127.0.0.1 local1 notice
maxconn 4096
chroot /var/lib/haproxy
stats socket /run/haproxy/admin.sock mode 660 level admin
stats timeout 30s
user haproxy
group haproxy
daemon

# Default SSL material locations
ca-base /etc/ssl/certs
crt-base /etc/ssl/private

# Default ciphers to use on SSL-enabled listening sockets.
# For more information, see ciphers(1SSL). This list is from:
#  https://hynek.me/articles/hardening-your-web-servers-ssl-ciphers/
# An alternative list with additional directives can be obtained from
#  https://mozilla.github.io/server-side-tls/ssl-config-generator/?server=haproxy
ssl-default-bind-ciphers ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:RSA+AESGCM:RSA+AES:!aNULL:!MD5:!DSS
ssl-default-bind-options no-sslv3

defaults
log global
mode http
option httplog
option dontlognull
retries 3
option redispatch
maxconn 2000
conntimeout 5000
clitimeout 50000
srvtimeout 50000

listen loadbalance 0.0.0.0:1936
mode http
stats enable
stats uri /haproxy?stats
option httpclose
option forwardfor
balance roundrobin
server webserver1 10.20.20.10:80 check
server webserver2 10.20.20.20:80 check

and the error said :

![image|690x352]

i will be appreciate and will get much knowledge from u master, thanks for your attention and your time :blush:

Could you perhaps run haproxy -c -f /etc/haproxy/haproxy.cfg (adapt if necessary), which checks and reports if there is something wrong with the configuration file.

Perhaps also try to run it in the foreground as haproxy -d -f /etc/haproxy/haproxy.cfg

done . i change my haproxy.cfg , like this :
image

and its works :

Thank you for responding
:blush: